Potential Outlook Email Failures and Errors
Incident Report for Alyce
Resolved
We've released a fix for this issue. If you're seeing any errors please reach out to support@alyce.com and we'll assist as soon as we can.
Posted Jun 10, 2021 - 18:18 EDT
Identified
We've found the root cause of the issue and are working on a fix now. We'll confirm when this is in place.
Posted Jun 10, 2021 - 17:33 EDT
Investigating
We've identified an issue where some emails sent by users integrated with Outlook may fail or cause errors. We're investigating now, we'll provide an update as soon as we can.
Posted Jun 10, 2021 - 17:20 EDT
This incident affected: Email Delivery.