Meetings schedule issue
Incident Report for Alyce
Resolved
The issue has been resolved.
Posted Feb 28, 2020 - 07:32 EST
Update
We are continuing to investigate this issue.
Posted Feb 28, 2020 - 07:30 EST
Investigating
We are currently investigating a problem that makes some meetings to be scheduled in the wrong timeframe. This problem impacts only a small percentage of meetings in specific circumstances. All the affected Gifts will be identified and fixed, users notified.
Posted Feb 28, 2020 - 07:30 EST